1. Fabrik 3.9 has been released. If you have updated Joomla to 3.9, this is a required update.
    Dismiss Notice

submit behavior of form embedded in an article using the content plugin

Discussion in 'Professional Support' started by skyrun, Jan 10, 2019.

  1. skyrun

    skyrun Active Member

    Level: Professional
    i have embeded a simple form into an article here (publicly viewable):
    https://testlocation.skyrun.com/owners

    BEFORE SUBMISSION:
    upload_2019-1-10_12-57-26.png

    this was embedded with a plugin in the article that looks like this {fabrik view=form id=191}

    when i submit the form by pressing 'send', it processes the form (i get an email from the email plugin, a record gets added to the db and i get the 'success' message.) however the form re-displays but WITHOUT the 3 required fields.
    AFTER SUBMISSION:
    upload_2019-1-10_12-57-1.png
     
  2. troester

    troester Well-Known Member Staff Member

    Level: Community
    I just tested your form and can't replicate, the form is displayed again with all fields.
    But the button says "Send inquiry!" so it seems you've changed something.
     
  3. skyrun

    skyrun Active Member

    Level: Professional
    it does indeed seem to work for me now too. go figure... perhaps some caching issue.

    would be better to have the 'success' message displayed on the page in a joomla message area vs. a js alert box (or on the form), and for the validation messages to not be tooltips and display under the elements (the way this same form does if i display it on a menu item, but this isn't too bad. i could always redirect to a version of the page that doesn't have the form if i wanted it to look that that post-submission.

    PS: it takes some work to split up the contant, but we've had luck creating modules to display the content on top and under a form, then having the menu item display the form. fabrik seems happier when displayed as a menu item vs. the content plugin.
     

Share This Page