1. Fabrik 3.8.1 has been released. It is mostly bug fixes and feature enhancements, but does include two new plugins (push notifications, and the sequence element). As usual we strongly recommend testing the new release on a sandbox if your application is mission critical, and always do an Akeeba backup before updating.

Upsert problem

Discussion in 'Professional Support' started by rodeokid, Apr 12, 2018.

  1. rodeokid

    rodeokid Member

    Level: Professional
    I use the upsert plugin on one form to send only important infos from this form to another table for our needs. Everything works fine for all elements except date_time , when the upsert plugin sends the data, the second table have 0000-00-00 00:00:00 for date_time.
    Both are in UTC. Same database table structure.
    I can't find the bug.

    Thanks.
    rodeokid
     
    Last edited: Apr 13, 2018
  2. rodeokid

    rodeokid Member

    Level: Professional
    Any idea ?
     
  3. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    I can't replicate this, dates upsert correctly in both my upsert test forms.

    What are the exact settings of your date element? Either screenshot them, or if it's on your Naya site, let me know which form / element it is and I'll look.

    -- hugh
     
  4. rodeokid

    rodeokid Member

    Level: Professional
    Sorry for the delay... busy weekend.
    Yes it's my Naya site.

    You can find the original form here : index.php?option=com_fabrik&view=list&listid=48&Itemid=237
    Here is the second form that receive the upsert datas : index.php?option=com_fabrik&view=list&listid=55&Itemid=266

    Original database table : rapport_production_embouteillage_1
    Upsert database table : rapport_production_par_quart

    I left one entry in the upsert database table so that you can see the date_time bug.

    Thanks...

    rodeokid
     
  5. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    Is this happening when inserting (new record), updating, or both?

    -- hugh
     
  6. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    BTW, your site is telling me "403 forbidden".

    -- hugh
     
  7. rodeokid

    rodeokid Member

    Level: Professional
    I am just moving my site to another folder right now...lolll...give me a minute, it will be ok.

    And it happens on both...New record or updating existing one.

    rodeokid
     
  8. rodeokid

    rodeokid Member

    Level: Professional
    Back online now...
     
  9. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    *phew*

    I was looking at the backend, and it quit working ... thought I'd broken it ... :)

    -- hugh
     
  10. rodeokid

    rodeokid Member

    Level: Professional
    By the way, this site is a work in progress, we are not working live on it, just test purpose for now, so don't worry testing what you want...lollll
     
  11. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    OK, try now. I haven't tested as I don't want to mess with your data, but I hope that'll fix it.

    The issue seems to be that your date element is a link, so the non-raw placeholder has the link HTML wrapped around it ... so I've added _raw to the placeholder name, which will get you the raw date without the formatting.

    -- hugh
     
  12. rodeokid

    rodeokid Member

    Level: Professional
    Oups...now i have an error whenever i try to save the form... syntax error, unexpected '05' (T_LNUMBER)

    05 is the first 2 digits of the hour... i tried another one starting with 02, and the error is the same but with '02'
    No upsert at all...
    rodeokid
     
  13. rodeokid

    rodeokid Member

    Level: Professional
    Ok i saw that you worked on it... it works now but in access you had to set everything to public, so i guess it's not finished yet ?
    Thanks

    rodeokid
     
  14. cheesegrits

    cheesegrits Support Gopher Staff Member

    Level: Professional
    I don't remember changing any access settings, so just set 'em how you want 'em.

    Thought I'd replied about that error ... I forgot to set the 'eval' option back to No after doing some testing.

    -- hugh
     

Share This Page